配资之家

分析家公式网,免费股票公式,股票软件下载站 用户登录  | 
买卖连线(通达信公式 主图 源码 测试图)详细解说
  • 软件大小:2.00 KB
  • 推荐星级:
  • 更新时间:2020-01-10 14:52:33
  • 软件类别: 国产软件 / 通达信公式
  • 软件语言:简体中文
  • 授权方式: 免费版
  • 配资开户 方式:暂无配资开户 方式
  • 官方主页: Home Page
  • 点击大图:  【一键转帖到论坛】
  • 插件情况:
  • 运行环境:Win9X/Win2000/WinXP/Win2003/Win7/
  • 相关Tags:买卖连线  
  • (0)0%
    (0)0%

软件介绍

 炒股票多了以后,通常对个股的交易价格记不精确,想复牌的那时候很不方便,假如有方法能够在K曲线图上标识买和卖点部位就好啦,

 
但是找了好长时间也没寻找那样的方式,因此自身写了一个程序,依据证券行情软件中的历史时间交易数据炒股配资 ,转化成能够立即应用的通达信源码,拷贝到通达信的代码编辑器中就能够在K曲线图上立即显示炒股配资 ,能够形象化地看得出买和卖点的部位,更为刻骨铭心地认识自己的实际操作缺陷,有利于找到难题,改善买卖方式。
 

想起将会也是许多人有这一要求,因此共享给大伙儿应用,期望大伙儿都能刻骨铭心地掌握到自身的买卖方式优劣,不断完善缺陷,保持平稳赢利。

先上源码,是主图的

{买卖连线}
{为便于显示买卖连线以单色绘制K线} 
{参数DANSE=1}
STICKLINE(C<=O,C,O,2.8,0),COLORGRAY;
STICKLINE(C>O,C,O,2.8,1),COLORGRAY;
STICKLINE(1,H,MAX(C,O),0,0),COLORGRAY;
STICKLINE(1,L,MIN(C,O),0,0),COLORGRAY;
{交易箴言提示}
DRAWTEXT_FIX(C>0,0.01,0.004,0,'买卖连线 【计划你的交易,交易你的计划 xfha119.cn】'),COLOR00DDFF,LINETHICK2;
 
 
运用的方法:
1、下载软件压缩包,本软件是绿色软件,下载之后解压缩即可。在使用之前需要先设置好数据目录和输出目录(可以与数据目录相同),以及数据的字段映射文件。
2、使用券商提供的交易软件中查询功能,查询“历史成交”,导出文本文件,有些券商不允许一次性导出全部数据,可以分批次导出,比如按月导出数据,文件名分别为:201911 历史成交查询.txt’、‘201912 历史成交查询.txt’之类,保存在一个数据目录下,记得所有数据文件名末尾部分必须是‘历史成交查询.txt’,否则软件不会读取该数据。
3、配置字段映射文件,在下载的软件压缩包中有FieldMap.txt文件,按照文件中的提示配置好字段映射后,保存在数据目录下。
4、启动本软件,选择数据文件所在的目录。
5、点击”执行程序”按钮,软件会将数据文件转换成通达信格式的买卖连线公式代码。
6、点击”统计查询”按钮,双击列表中出现的股票代码,即可将该股票的买卖连线公式代码复制入剪贴板。
7、将软件压缩包中的“通达信买卖连线.tn6”导入到通达信行情软件中,选择该股票,键盘输入”MML”即可启用“买卖连线”指标,用ALT+S调出公式编辑器,全选该指标的代码,然后将剪贴板上的通达信代码粘贴进 公式编辑器,点确定即可在K线图上看到买卖连线。
 
 
 
 
 
 
 
 
 
 
 
 
 
 

空白指标(不需要独立下载,文件已经放入后面的压缩包),内容更新后可用,主要是用到了参数的开关选项
 
举例:完整的通达信连线代码如下:
 
{为便于显示买卖连线以单色绘制K线} 
STICKLINE(DANSE AND C<=O,C,O,2.8,0),COLORGRAY;
STICKLINE(DANSE AND C>O,C,O,2.8,1),COLORGRAY;
STICKLINE(DANSE,H,MAX(C,O),0,0),COLORGRAY;
STICKLINE(DANSE,L,MIN(C,O),0,0),COLORGRAY;
 
{交易箴言提示}
DRAWTEXT_FIX(C>0,0.01,0.004,0,'买卖连线 【计划你的交易,交易你的计划】'),COLOR00DDFF,LINETHICK2;
D01S:=1190916;T01S:=0934;P01S:=26.750;D01E:=1190923;T01E:=0935;P01E:=24.350;S01:=1000;
D02S:=1191203;T02S:=1452;P02S:=24.410;D02E:=1191210;T02E:=0930;P02E:=23.370;S02:=1000;
D03S:=1191216;T03S:=0932;P03S:=24.960;D03E:=1191224;T03E:=0931;P03E:=27.890;S03:=1000;
D04S:=1191220;T04S:=0934;P04S:=29.080;D04E:=1191227;T04E:=1029;P04E:=29.041;S04:=1000;
D05S:=1200102;T05S:=1418;P05S:=30.660;D05E:=1200108;T05E:=0910;P05E:=30.660;S05:=1000;
C01S:=IF(PERIOD<5,DATE=D01S AND T01S<=TIME AND (T01S>REF(TIME,1) OR D01S>REF(DATE,1)), D01S<=DATE AND D01S>REF(DATE,1));
C01E:=IF(PERIOD<5,DATE=D01E AND T01E<=TIME AND (T01E>REF(TIME,1) OR D01E>REF(DATE,1)), D01E<=DATE AND D01E>REF(DATE,1));
LINE01:DRAWLINE(C01S,P01S,C01E,P01E,0),COLORGREEN,LINETHICK1;
C02S:=IF(PERIOD<5,DATE=D02S AND T02S<=TIME AND (T02S>REF(TIME,1) OR D02S>REF(DATE,1)), D02S<=DATE AND D02S>REF(DATE,1));
C02E:=IF(PERIOD<5,DATE=D02E AND T02E<=TIME AND (T02E>REF(TIME,1) OR D02E>REF(DATE,1)), D02E<=DATE AND D02E>REF(DATE,1));
LINE02:DRAWLINE(C02S,P02S,C02E,P02E,0),COLORGREEN,LINETHICK1;
C03S:=IF(PERIOD<5,DATE=D03S AND T03S<=TIME AND (T03S>REF(TIME,1) OR D03S>REF(DATE,1)), D03S<=DATE AND D03S>REF(DATE,1));
C03E:=IF(PERIOD<5,DATE=D03E AND T03E<=TIME AND (T03E>REF(TIME,1) OR D03E>REF(DATE,1)), D03E<=DATE AND D03E>REF(DATE,1));
LINE03:DRAWLINE(C03S,P03S,C03E,P03E,0),COLORRED,LINETHICK1;
C04S:=IF(PERIOD<5,DATE=D04S AND T04S<=TIME AND (T04S>REF(TIME,1) OR D04S>REF(DATE,1)), D04S<=DATE AND D04S>REF(DATE,1));
C04E:=IF(PERIOD<5,DATE=D04E AND T04E<=TIME AND (T04E>REF(TIME,1) OR D04E>REF(DATE,1)), D04E<=DATE AND D04E>REF(DATE,1));
LINE04:DRAWLINE(C04S,P04S,C04E,P04E,0),COLORGREEN,LINETHICK1;
C05S:=IF(PERIOD<5,DATE=D05S AND T05S<=TIME AND (T05S>REF(TIME,1) OR D05S>REF(DATE,1)), D05S<=DATE AND D05S>REF(DATE,1));
C05E:=IF(PERIOD<5,DATE=D05E AND T05E<=TIME AND (T05E>REF(TIME,1) OR D05E>REF(DATE,1)), D05E<=DATE AND D05E>REF(DATE,1));
LINE05:DRAWLINE(C05S,P05S,ISLASTBAR,P05E,0),COLORYELLOW,LINETHICK1;
IF(CURRBARSCOUNT<20 AND (DATE<D05S OR (DATE=D05S AND TIME<=T05S)),CONST(P05S),DRAWNULL),COLORWHITE;





附件里,有一个文件:历史成交查询程序。
压缩包(包含指标、目录、配置文件等)
说明:本程序是自写自用的程序,并非商业软件,未做很多强壮性的检查,在论坛曾经受益所以愿意无偿分享给大家,要求高的朋友请绕道,如果出现错误退出等,大多是数据文件字段没有设置正确,请检查后再试。
下载地址:http://www.lanzous.com/i8l1t8h

下载地址(点击下图进入下载地址网页)

    买卖连线(通达信公式 主图 源码 测试图)详细解说下载

软件评论评论内容只代表网友观点,与本站立场无关!

   评论摘要(共 0 条,得分 0 分,平均 0 分) 查看完整评论

下载说明

* 下载方法:点击上面的绿色图片(图片有“下载地址”文字),就新开一个页面,点击“本地高速下载”,或者点击文字“下载地址1”即可下载软件

* 本网站提供的各种股票软件,例如大智慧软件,通达信软件,同花顺软件,飞狐,文华期货软件,手机炒股软件,指南针,东方财富通等等,和各种股票公式指标,例如大智慧公式,通达信公式,同花顺公式,操盘手公式,文华公式,飞狐公式,博易大师公式,股票价格计算公式等等公式指标,还有各类股票书籍都来源网上可以免费下载
* 请一定升级到最新版WinRAR才能正常解压本站提供的软件!

本网提供的公式文件说明:
* alg格式飞狐股票公式,可以用飞狐交易师或者交易师软件导入;
* fnc格式大智慧新一代公式指标,可以用大智慧新一代高速行情分析系统股票软件使用,少部分可以用分析家股票软件引入使用;
* exp格式大智慧经典版股票公式,仅可以用大智慧经典版股票软件引入使用;
* tni和tnc格式通达信股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
* tne,tn6格式通达信公式,可以用通达信公式编辑器5.0版导入,推荐通达信短线极品版本;
* hxf格式同花顺股票公式,仅可以用同花顺股票软件引入使用。
以上的各种软件都可以在本网股票软件栏目找到并下载!

* 配资公司 股票公式时间限制,如果在引入大智慧公式,交易师公式或者飞狐公式的时候,发现公式名称栏是空白的,这时候调整电脑时间到1997年,又能出现公式名称 ,并且能正常显示,可能是公式使用期限已过。
* 配资公司 公式解密收费解密大智慧公式,通达信公式,同花顺公式,操盘手公式,飞狐公式,博易大师公式,文华公式和外汇EA等等源码,可解密完全加密定向加密公式或延时,收费服务无意勿扰,配资开户 QQ984388831。

* 配资公司 股票公式源码编辑
本网提供的源码,一般都可以编辑成公式,如果不明白公式的编辑,在本页右侧教程录像可参考,或者找公式教程资料学习,请搜索:教程

* 如果您发现下载链接错误,请点击报告错误谢谢!
* 站内提供的所有软件包含和谐及注册码均是由网上搜集,若侵犯了你的版权利益,敬请来信通知我们!

配资公司 本站 | 网站帮助 | 广告合作 | 下载声明 | 友情连接 | 网站地图 |

声明:本站所有股票软件、股票书籍和股票期货配资 均免费。站内所有广告,如有收费行为,均与本站无任何关系!请网友小心谨慎。
Copyright © 2003-2008 70822.Com. All Rights Reserved .
页面执行时间:140.62500 毫秒

配资之家